Hébergeur de fichiers indépendant

DM.alg

À propos

Type de fichier
Fichier ALG de 5 Ko (application/xml)
Confidentialité
Fichier public, envoyé le 30 décembre 2015 à 18:34, depuis l'adresse IP 81.65.x.x (France)
Sécurité
Ne contient aucun Virus ou Malware connus - Dernière vérification: 3 jours
Statistiques
La présente page de téléchargement a été vue 489 fois depuis l'envoi du fichier
Page de téléchargement

Aperçu du fichier


<?xml version="1.0" encoding="UTF-8"?>
<Algo>
    <description courant="SI (n1==n2 ET n2==n3 ET n1==n3) ALORS" texte=""/>
    <extension extnom="inactif"/>
    <fonction fctetat="inactif" fctcode=""/>
    <F2 F2defaut="" F2etat="inactif" F2para="" F2lignes=""/>
    <repere repetat="inactif" repcode="-10#10#-10#10#2#2"/>
    <item code="100#declarationsvariables" algoitem="VARIABLES">
        <item code="1#NOMBRE#a" algoitem="a EST_DU_TYPE NOMBRE"/>
        <item code="1#NOMBRE#b" algoitem="b EST_DU_TYPE NOMBRE"/>
        <item code="1#NOMBRE#c" algoitem="c EST_DU_TYPE NOMBRE"/>
        <item code="1#NOMBRE#d" algoitem="d EST_DU_TYPE NOMBRE"/>
        <item code="1#NOMBRE#f" algoitem="f EST_DU_TYPE NOMBRE"/>
        <item code="1#NOMBRE#x" algoitem="x EST_DU_TYPE NOMBRE"/>
        <item code="1#NOMBRE#y" algoitem="y EST_DU_TYPE NOMBRE"/>
        <item code="1#NOMBRE#e" algoitem="e EST_DU_TYPE NOMBRE"/>
        <item code="1#NOMBRE#n1" algoitem="n1 EST_DU_TYPE NOMBRE"/>
        <item code="1#NOMBRE#n2" algoitem="n2 EST_DU_TYPE NOMBRE"/>
        <item code="1#NOMBRE#n3" algoitem="n3 EST_DU_TYPE NOMBRE"/>
        <item code="1#NOMBRE#n4" algoitem="n4 EST_DU_TYPE NOMBRE"/>
        <item code="1#NOMBRE#n5" algoitem="n5 EST_DU_TYPE NOMBRE"/>
        <item code="1#NOMBRE#n6" algoitem="n6 EST_DU_TYPE NOMBRE"/>
        <item code="1#NOMBRE#n7" algoitem="n7 EST_DU_TYPE NOMBRE"/>
    </item>
    <item code="101#debutalgo" algoitem="DEBUT_ALGORITHME">
        <item code="4#Coefficient a de la première droite ? : #0" algoitem="AFFICHER &quot;Coefficient a de la première droite ? : &quot;"/>
        <item code="2#a#pasliste" algoitem="LIRE a"/>
        <item code="4#Coefficient b de la première droite ? : #0" algoitem="AFFICHER &quot;Coefficient b de la première droite ? : &quot;"/>
        <item code="2#b#pasliste" algoitem="LIRE b"/>
        <item code="4#Coefficient c de la première droite ? : #0" algoitem="AFFICHER &quot;Coefficient c de la première droite ? : &quot;"/>
        <item code="2#c#pasliste" algoitem="LIRE c"/>
        <item code="4#Coefficient a' de la deuxième droite ? : #0" algoitem="AFFICHER &quot;Coefficient a' de la deuxième droite ? : &quot;"/>
        <item code="2#d#pasliste" algoitem="LIRE d"/>
        <item code="4#Coefficient b' de la deuxième droite ? : #0" algoitem="AFFICHER &quot;Coefficient b' de la deuxième droite ? : &quot;"/>
        <item code="2#e#pasliste" algoitem="LIRE e"/>
        <item code="4#Coefficient c' de la deuxième droite ? : #0" algoitem="AFFICHER &quot;Coefficient c' de la deuxième droite ? : &quot;"/>
        <item code="2#f#pasliste" algoitem="LIRE f"/>
        <item code="5#n1#a/d#pasliste" algoitem="n1 PREND_LA_VALEUR a/d"/>
        <item code="5#n2#b/e#pasliste" algoitem="n2 PREND_LA_VALEUR b/e"/>
        <item code="5#n3#c/f#pasliste" algoitem="n3 PREND_LA_VALEUR c/f"/>
        <item code="6#n1==n2 ET n2==n3 ET n1==n3" algoitem="SI (n1==n2 ET n2==n3 ET n1==n3) ALORS">
            <item code="7#debutsi" algoitem="DEBUT_SI"/>
            <item code="4#Les droites sont confondues.#0" algoitem="AFFICHER &quot;Les droites sont confondues.&quot;"/>
            <item code="8#finsi" algoitem="FIN_SI"/>
            <item code="9#sinon" algoitem="SINON">
                <item code="10#debutsinon" algoitem="DEBUT_SINON"/>
                <item code="5#n4#-b/(-e)#pasliste" algoitem="n4 PREND_LA_VALEUR -b/(-e)"/>
                <item code="5#n5#a/d#pasliste" algoitem="n5 PREND_LA_VALEUR a/d"/>
                <item code="6#n4==n5" algoitem="SI (n4==n5) ALORS">
                    <item code="7#debutsi" algoitem="DEBUT_SI"/>
                    <item code="4#Les droites sont disjointes.#0" algoitem="AFFICHER &quot;Les droites sont disjointes.&quot;"/>
                    <item code="8#finsi" algoitem="FIN_SI"/>
                    <item code="9#sinon" algoitem="SINON">
                        <item code="10#debutsinon" algoitem="DEBUT_SINON"/>
                        <item code="5#n6#(c*e-f*b)/(a*e-b*d)#pasliste" algoitem="n6 PREND_LA_VALEUR (c*e-f*b)/(a*e-b*d)"/>
                        <item code="5#n7#(a*f-c*d)/(a*e-b*d)#pasliste" algoitem="n7 PREND_LA_VALEUR (a*f-c*d)/(a*e-b*d)"/>
                        <item code="4#Les droites sont sécantes en (#0" algoitem="AFFICHER &quot;Les droites sont sécantes en (&quot;"/>
                        <item code="3#n6#0#pasliste" algoitem="AFFICHER n6"/>
                        <item code="4#;#0" algoitem="AFFICHER &quot;;&quot;"/>
                        <item code="3#n7#0#pasliste" algoitem="AFFICHER n7"/>
                        <item code="4#).#0" algoitem="AFFICHER &quot;).&quot;"/>
                        <item code="11#finsinon" algoitem="FIN_SINON"/>
                    </item>
                </item>
                <item code="11#finsinon" algoitem="FIN_SINON"/>
            </item>
        </item>
    </item>
    <item code="102#finalgo" algoitem="FIN_ALGORITHME"/>
</Algo>


Partager le fichier


Télécharger DM.alg


Télécharger DM.alg