Hébergeur de fichiers indépendant

AlgorithmeMathRobin.alg

À propos

Type de fichier
Fichier ALG de 2 Ko (application/xml)
Confidentialité
Fichier public, envoyé le 2 mars 2015 à 19:45, depuis l'adresse IP 5.158.x.x (France)
Sécurité
Ne contient aucun Virus ou Malware connus - Dernière vérification: 3 jours
Statistiques
La présente page de téléchargement a été vue 299 fois depuis l'envoi du fichier
Page de téléchargement

Aperçu du fichier


<?xml version="1.0" encoding="UTF-8"?>
<Algo>
    <description texte="" courant="AFFICHER a"/>
    <extension extnom="inactif"/>
    <fonction fctcode="" fctetat="inactif"/>
    <F2 F2para="" F2lignes="" F2etat="inactif" F2defaut=""/>
    <repere repetat="inactif" repcode="-10#10#-10#10#2#2"/>
    <item algoitem="VARIABLES" code="100#declarationsvariables">
        <item algoitem="m EST_DU_TYPE NOMBRE" code="1#NOMBRE#m"/>
        <item algoitem="a EST_DU_TYPE NOMBRE" code="1#NOMBRE#a"/>
        <item algoitem="b EST_DU_TYPE NOMBRE" code="1#NOMBRE#b"/>
    </item>
    <item algoitem="DEBUT_ALGORITHME" code="101#debutalgo">
        <item algoitem="LIRE a" code="2#a#pasliste"/>
        <item algoitem="LIRE b" code="2#b#pasliste"/>
        <item algoitem="TANT_QUE (b-a>0.001) FAIRE" code="15#b-a>0.001">
            <item algoitem="DEBUT_TANT_QUE" code="16#debuttantque"/>
            <item algoitem="m PREND_LA_VALEUR (a+b)/2" code="5#m#(a+b)/2#pasliste"/>
            <item algoitem="SI (F1(m)>0) ALORS" code="6#F1(m)>0">
                <item algoitem="DEBUT_SI" code="7#debutsi"/>
                <item algoitem="b PREND_LA_VALEUR m" code="5#b#m#pasliste"/>
                <item algoitem="FIN_SI" code="8#finsi"/>
                <item algoitem="SINON" code="9#sinon">
                    <item algoitem="DEBUT_SINON" code="10#debutsinon"/>
                    <item algoitem="a PREND_LA_VALEUR m" code="5#a#m#pasliste"/>
                    <item algoitem="FIN_SINON" code="11#finsinon"/>
                </item>
            </item>
            <item algoitem="FIN_TANT_QUE" code="17#fintantque"/>
        </item>
        <item algoitem="AFFICHER &quot;a = &quot;" code="4#a = #0"/>
        <item algoitem="AFFICHER a" code="3#a#1#pasliste"/>
        <item algoitem="AFFICHER &quot;b = &quot;" code="4#b = #0"/>
        <item algoitem="AFFICHER b" code="3#b#0#pasliste"/>
    </item>
    <item algoitem="FIN_ALGORITHME" code="102#finalgo"/>
</Algo>


Partager le fichier

Télécharger AlgorithmeMathRobin.alg

Télécharger le fichier (2 Ko)