Hébergeur de fichiers indépendant

Algo Triangle Rectangle.alg

À propos

Type de fichier
Fichier ALG de 2 Ko (application/xml)
Confidentialité
Fichier public, envoyé le 18 décembre 2013 à 09:22, depuis l'adresse IP 217.128.x.x (France)
Sécurité
Ne contient aucun Virus ou Malware connus - Dernière vérification: hier
Statistiques
La présente page de téléchargement a été vue 437 fois depuis l'envoi du fichier
Page de téléchargement

Aperçu du fichier


<?xml version="1.0" encoding="UTF-8"?>
<Algo>
    <description texte="" courant="AFFICHER &quot;Le triangle n'est pas rectangle !&quot;"/>
    <extension extnom="inactif"/>
    <fonction fctcode="" fctetat="inactif"/>
    <F2 F2defaut="" F2lignes="" F2etat="inactif" F2para=""/>
    <repere repetat="inactif" repcode="-10#10#-10#10#2#2"/>
    <item algoitem="VARIABLES" code="100#declarationsvariables">
        <item algoitem="a EST_DU_TYPE NOMBRE" code="1#NOMBRE#a"/>
        <item algoitem="b EST_DU_TYPE NOMBRE" code="1#NOMBRE#b"/>
        <item algoitem="c EST_DU_TYPE NOMBRE" code="1#NOMBRE#c"/>
    </item>
    <item algoitem="DEBUT_ALGORITHME" code="101#debutalgo">
        <item algoitem="LIRE a" code="2#a#pasliste"/>
        <item algoitem="LIRE b" code="2#b#pasliste"/>
        <item algoitem="LIRE c" code="2#c#pasliste"/>
        <item algoitem="a PREND_LA_VALEUR pow(a,2)" code="5#a#pow(a,2)#pasliste"/>
        <item algoitem="b PREND_LA_VALEUR pow(b,2)" code="5#b#pow(b,2)#pasliste"/>
        <item algoitem="c PREND_LA_VALEUR pow(c,2)" code="5#c#pow(c,2)#pasliste"/>
        <item algoitem="SI (a + b == c) ALORS" code="6#a + b == c">
            <item algoitem="DEBUT_SI" code="7#debutsi"/>
            <item algoitem="AFFICHER &quot;Le triangle est rectangle !&quot;" code="4#Le triangle est rectangle !#0"/>
            <item algoitem="FIN_SI" code="8#finsi"/>
            <item algoitem="SINON" code="9#sinon">
                <item algoitem="DEBUT_SINON" code="10#debutsinon"/>
                <item algoitem="AFFICHER &quot;Le triangle n'est pas rectangle !&quot;" code="4#Le triangle n'est pas rectangle !#0"/>
                <item algoitem="FIN_SINON" code="11#finsinon"/>
            </item>
        </item>
    </item>
    <item algoitem="FIN_ALGORITHME" code="102#finalgo"/>
</Algo>


Partager le fichier


Télécharger Algo Triangle Rectangle.alg


Télécharger Algo Triangle Rectangle.alg