Hébergeur de fichiers indépendant

TD 4.1.alg

À propos

Type de fichier
Fichier ALG de 2 Ko (application/xml)
Confidentialité
Fichier public, envoyé le 10 octobre 2012 à 21:07, depuis l'adresse IP 212.198.x.x (France)
Sécurité
Ne contient aucun Virus ou Malware connus - Dernière vérification: 3 jours
Statistiques
La présente page de téléchargement a été vue 417 fois depuis l'envoi du fichier
Page de téléchargement

Aperçu du fichier


<?xml version="1.0" encoding="UTF-8"?>
<Algo>
    <description texte="" courant="AFFICHER &quot;A=&quot;"/>
    <extension extnom="inactif"/>
    <fonction fctcode="" fctetat="inactif"/>
    <F2 F2defaut="" F2lignes="" F2etat="inactif" F2para=""/>
    <repere repetat="inactif" repcode="-10#10#-10#10#2#2"/>
    <item algoitem="VARIABLES" code="100#declarationsvariables">
        <item algoitem="N EST_DU_TYPE NOMBRE" code="1#NOMBRE#N"/>
        <item algoitem="A EST_DU_TYPE NOMBRE" code="1#NOMBRE#A"/>
    </item>
    <item algoitem="DEBUT_ALGORITHME" code="101#debutalgo">
        <item algoitem="LIRE N" code="2#N#pasliste"/>
        <item algoitem="SI (N%2==0) ALORS" code="6#N%2==0">
            <item algoitem="DEBUT_SI" code="7#debutsi"/>
            <item algoitem="A PREND_LA_VALEUR N/2" code="5#A#N/2#pasliste"/>
            <item algoitem="AFFICHER &quot;N est bien un nombre entier. Donc A=N/2&quot;" code="4#N est bien un nombre entier. Donc A=N/2#0"/>
            <item algoitem="FIN_SI" code="8#finsi"/>
            <item algoitem="SINON" code="9#sinon">
                <item algoitem="DEBUT_SINON" code="10#debutsinon"/>
                <item algoitem="A PREND_LA_VALEUR (N+1)/2" code="5#A#(N+1)/2#pasliste"/>
                <item algoitem="AFFICHER &quot;N n'est pas un entier. A=(N+1)/2&quot;" code="4#N n'est pas un entier. A=(N+1)/2#1"/>
                <item algoitem="FIN_SINON" code="11#finsinon"/>
            </item>
        </item>
        <item algoitem="AFFICHER &quot;A=&quot;" code="4#A=#0"/>
        <item algoitem="AFFICHER A" code="3#A#0#pasliste"/>
    </item>
    <item algoitem="FIN_ALGORITHME" code="102#finalgo"/>
</Algo>


Partager le fichier

Télécharger TD 4.1.alg

Télécharger le fichier (2 Ko)